Commit fbd03dbf authored by Andre Maroneze's avatar Andre Maroneze 💬
Browse files

Merge branch 'feature/andre/update-dockerfile-25' into 'master'

[Dev] update Docker Makefile for release 25.0

See merge request frama-c/frama-c!3830
parents 91641d09 7c5cb2a0
......@@ -137,6 +137,61 @@ sed 's|@FRAMAC_TESTS@|sudo apk add ncurses \&\& cd /frama-c \&\& make tests PTES
sed 's|@OCAMLV@|4.08|g' | \
cat > $@
25.0-stripped: Dockerfile.25.0
docker build . -t framac/frama-c:$@ --target frama-c-stripped -f $^ \
--build-arg=from_archive=https://www.frama-c.com/download/frama-c-25.0-Manganese.tar.gz $(ARGS)
TARGETS += 25.0-stripped
25.0: Dockerfile.25.0
docker build . -t framac/frama-c:$@ --target frama-c-slim -f $^ \
--build-arg=from_archive=https://www.frama-c.com/download/frama-c-25.0-Manganese.tar.gz $(ARGS)
TARGETS += 25.0
25.0-gui: Dockerfile.25.0
docker build . -t framac/frama-c-gui:25.0 --target frama-c-gui-slim -f $^ \
--build-arg=from_archive=https://www.frama-c.com/download/frama-c-25.0-Manganese.tar.gz $(ARGS)
TARGETS += 25.0-gui
push-25.0: 25.0 25.0-gui 25.0-stripped
docker push framac/frama-c:25.0
docker push framac/frama-c-gui:25.0
docker push framac/frama-c:25.0-stripped
Dockerfile.25.0: Makefile Dockerfile.template env.template
sed 's|@ALPINE_OPAM_BASE@|ocaml/opam:alpine-3.13-ocaml-4.08|g' Dockerfile.template | \
sed 's|@ALPINE_BASE@|alpine:3.13|g' | \
sed 's|@ENV@|$(shell cat env.template)|g' | \
sed 's|@CVC4@|$(shell cat cvc4.template)|g' | \
sed 's|@CVC4_VERSION@|1.7|g' | \
sed 's|@Z3@|$(shell cat z3.template)|g' | \
sed 's|@OPAM_CACHE_FIX@|opam repository set-url default https://opam.ocaml.org \&\&|g' | \
sed 's|@OPAM_SWITCH@|true|g' | \
sed 's|@OPAM_DEPS@|\\\
alt-ergo.2.2.0 \\\
apron.v0.9.12 \\\
conf-graphviz.0.1 \\\
mlgmpidl.1.2.12 \\\
ocamlfind.1.8.1 \\\
ocamlgraph.1.8.8 \\\
ppx_deriving_yojson.3.6.1 \\\
ppx_import.1.9.0 \\\
why3.1.5.0 \\\
yojson.1.7.0 \\\
zarith.1.10 \\\
zmq.5.1.3 \\\
conf-python-3.1.0.0 \\\
conf-time.1|' | \
sed 's|@PATCH_FRAMAC@|true|g' | \
sed 's|@WP_REPORT@|-wp -report|g'| \
sed 's|@WHY3_CONFIG@|why3 config detect|g' | \
sed 's|@WP_TEST@|frama-c -wp wp_gallery/binary-multiplication-without-overflow.c -wp-prover alt-ergo,cvc4,z3|g' | \
sed 's|@GUI_ALPINE_DEPS@||g' | \
sed 's|@GUI_OPAM_DEPS@|lablgtk3 lablgtk3-sourceview3 conf-gtksourceview3|g' | \
sed 's|@GUI_REMAKE@|make clean \&\& ./configure --enable-gui \&\& make -j \&\& sudo make install|g' | \
sed 's|@FRAMAC_TESTS@|sudo apk add ncurses \&\& cd /frama-c \&\& make tests PTESTS_OPTS=-error-code|g' | \
sed 's|@OCAMLV@|4.08|g' | \
cat > $@
24.0-stripped: Dockerfile.24.0
docker build . -t framac/frama-c:$@ --target frama-c-stripped -f $^ \
--build-arg=from_archive=https://www.frama-c.com/download/frama-c-24.0-Chromium.tar.gz $(ARGS)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment