Commit d120413b authored by Andre Maroneze's avatar Andre Maroneze 💬
Browse files

[opam] update compatible versions in depends

parent 3bf10449
......@@ -102,13 +102,13 @@ run-test: [
]
depends: [
"ocaml" { >= "4.05.0" & ( < "4.08.0~" | >= "4.08.1" ) }
"ocaml" { >= "4.08.1" }
"ocamlgraph" { >= "1.8.8" & < "1.9~" }
"ocamlfind" # needed beyond build stage, used by -load-module
"zarith"
"conf-autoconf" { build }
( ( "lablgtk" { >= "2.18.2" } & "conf-gnomecanvas" & "conf-gtksourceview" )
| ( "lablgtk3" { >= "3.0.beta4" & os!="macos" }
( ( "lablgtk" { >= "2.18.8" } & "conf-gnomecanvas" & "conf-gtksourceview" )
| ( "lablgtk3" { >= "3.1.0" & os!="macos" }
& "lablgtk3-sourceview3" & "conf-gtksourceview3" ) )
( "alt-ergo-free" | "alt-ergo" )
"conf-graphviz" { post }
......@@ -128,18 +128,9 @@ depopts: [
"ppx_deriving_yojson"
]
conflicts: [
"lablgtk" { < "2.18.2" } #for ocaml >= 4.02.1
"frama-c-e-acsl" #avoid mixing old releases of E-ACSL, it is already
#distributed with this version of Frama-C
"frama-c-base" #avoid mixing old releases of Frama-C, now that only the
#'frama-c' package exists
]
messages: [
"The Frama-C/Wp now uses Why-3 for all provers (Cf. deprecated -wp-prover native:alt-ergo)"
{alt-ergo:installed}
"The Frama-C/Wp native support for Coq is now deprecated (use TIP or Why-3 instead)."
{coq:installed}
"WARNING: There is a known issue with OCaml 4.05.0 and ocamlfind 1.8.1 (https://github.com/ocaml/opam-repository/issues/10925) when upgrading from a previous ocamlfind. If the compilation of Frama-C fails, try downgrading ocamlfind to 1.8.0 or upgrading OCaml to > 4.05.0." { ocaml:version = "4.05.0" & ocamlfind:version = "1.8.1" }
]
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment