Skip to content
Snippets Groups Projects
frama-ci.nix 425 B
#To copy in other repository
{ pkgs ? import <nixpkgs> {}, password}:

let
    src = builtins.fetchGit {
            "url" = "https://bobot:${password}@git.frama-c.com/frama-c/Frama-CI.git";
            "name" = "Frama-CI";
            "rev" = "cea0f2d2872e59fd3e6fe4634891a3765c7036e8";
            "ref" = "feature/opam2";
    };
 in
 {
  src = src;
  compiled = pkgs.callPackage "${src}/compile.nix" { inherit pkgs; };
 }